WordPress 4.5 jQuery Syntax errorで、FlexSlider 2が動かないときの対処法。

WordPress 4.5 jQuery Syntax errorで、FlexSlider 2が動かないときの対処法。-01

WordPress 4.5で、jQuery 1.12.3と jQuery Migrate 1.4.0のバージョンが同梱されました。

FlexSlider 2が表示されない

WordPress 4.5 jQuery Syntax errorで、FlexSlider 2が動かないときの対処法。-02

ブログやサイトにスライダーをお使いの方も多いと思います。こちらはFlexSlider 2というスライダーで表示されているのですが、WordPress 4.5にバージョンアップすると、うんともすんとも表示されません。

jQuery Migrate 1.4.0でエラー

WordPress 4.5 jQuery Syntax errorで、FlexSlider 2が動かないときの対処法。-03

ChromeのF12で検証してみると、何やらエラーがでています。jQuery Migrate 1.4.0が吐き出して、Javascriptが停止しています。

$('a[href^=#]').on( 'click', function() {} );

WordPress4.4は、この記述でOKですが、

$('a[href^="#"]').on( 'click', function() {} );

WordPress4.5だと、”#”と書き換えないと、構文エラーになります。参考になりました。ありがとうございます。

WP4.5でjQueryがエラー: Syntax error, unrecognized expression | サイトスパイラル(Sitespiral) – 沖縄で ホームページ制作 / WordPressのことなら : 

scripts.jsファイル

WordPress 4.5 jQuery Syntax errorで、FlexSlider 2が動かないときの対処法。-04

では、早速、FTPを起動して、テーマのscripts.jsファイルにアクセスします。

WordPress 4.5 jQuery Syntax errorで、FlexSlider 2が動かないときの対処法。-05

該当箇所を探します。#を”#”と引用符で囲います。

WordPress 4.5 jQuery Syntax errorで、FlexSlider 2が動かないときの対処法。-06

修正して上書き保存すると、スライダーが表示されるようになりました。メデタシメデタシ。

WordPressは便利なんですが、時々、こういうのがあるので面倒ですよね。
お疲れ様でした。